#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ".*?\b(\d{2})\.(\d{2})\.(\d{4})\b"
Local $sString = "Campaign on 01.11.2015"
Local $sSubst = "\3\2\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)