using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*?\b(\d{2})\.(\d{2})\.(\d{4})\b";
string substitution = @"\3\2\1";
string input = @"Campaign on 01.11.2015";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}