use strict;
my $str = 'Campaign on 01.11.2015';
my $regex = qr/.*?\b(\d{2})\.(\d{2})\.(\d{4})\b/p;
my $subst = '\\3\\2\\1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";