package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\s\d!@£$%^&*()+=]*$`)
var str = `123
jl
sdf$fd
fds fdsfds
23 123
James1
James
James Rose`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}