import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\s\\d!@£$%^&*()+=]*$";
final String string = "123\n\n"
+ "jl\n\n"
+ "sdf$fd\n\n"
+ "fds fdsfds\n"
+ "23 123\n\n"
+ "James1\n\n"
+ "James\n\n"
+ "James Rose";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}