$re = '/^[^\s\d!@£$%^&*()+=]*$/m';
$str = '123
jl
sdf$fd
fds fdsfds
23 123
James1
James
James Rose';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);