// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^\s\d!@£$%^&*()+=]*$").unwrap();
let string = "123
jl
sdf$fd
fds fdsfds
23 123
James1
James
James Rose";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}