$re = '/(%(.[^%]*)%)/';
$str = '$a = "%DATO1%, xxx %dato2% yyyy: %dato3%";';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);