re = /^\+?$/m
str = '+123456489
+1(850) 555-1234
+1-850-555-1234
+88 66 8880 1234
dsadsadas
3213123213
+123456489+
++1(850) 555-1234
3424324324+
sdsad989890
324324s32432
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end