import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(https?:\\/\\/(?:www\\.|(?!www))[a-zA-Z0-9][a-zA-Z0-9-]+[a-zA-Z0-9]\\.[^\\s]{2,}|www\\.[a-zA-Z0-9][a-zA-Z0-9-]+[a-zA-Z0-9]\\.[^\\s]{2,}|https?:\\/\\/(?:www\\.|(?!www))[a-zA-Z0-9]\\.[^\\s]{2,}|www\\.[a-zA-Z0-9]\\.[^\\s]{2,})$";
final String string = "http://video.google.co.uk:80/videoplay?docid=-72469230&hl=en#hello\n"
+ "https://ec2-52-74-229-167.ap.amazonaws.com/hive/admin/register\n"
+ "file:///C:/Users/thusharakrra/Desktop/index.html\n"
+ "localhost:8080\n"
+ "https://www.crimsonlogic.com\n"
+ "https://crimsonlogic.com\n"
+ "www.crimsonlogic.com\n"
+ "http://www.crimsonlogic.com\n"
+ "http://crimsonlogic.com\n"
+ "ftp://crimsonlogic.com\n"
+ "wwwcrimson.com\n"
+ "dsdsadasdasd\n"
+ "sdasdsahttps://dsadasd\n"
+ "sdasdsahttps://dsadasd.com\n"
+ "http://crimsonlogic.comdsadasd";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}