package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\((\d+),(\d+)\)`)
var str = `"AT (1,1) ADDROOM RM0001"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}