package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*\[ERR]\h*(?:\R.*\bException\b.*){2}`)
var str = `2023-03-15 18:14:31.149 -04:00 [ERR]
Exception Time: 3/15/2023 6:14:31 PM
Exception Message: Could not find file '\\XXXXX01\Files\51372\Working\.xml'.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}