import Foundation
let pattern = #".*\[ERR]\h*(?:\R.*\bException\b.*){2}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2023-03-15 18:14:31.149 -04:00 [ERR]
Exception Time: 3/15/2023 6:14:31 PM
Exception Message: Could not find file '\\XXXXX01\Files\51372\Working\.xml'.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)