import Foundation
let pattern = #"^.\K|.(?=.*@)|@.\K|\..*(*SKIP)(*F)|.(?=.*\.)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
abc@gmail.com
fdgdg@yahoo.com
abcsds@gmail.co.uk
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"*"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)