package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^.*?(\bEventname 2\b).*$`)
var str = `<select id="filter_event_id" name="filter_event_id" class="inputbox chzn-done" onchange="submit();" style="display: none;">
<option value="0">Select Event</option>
<option value="113">Eventname (RB113) (02-05-2015)</option>
<option value="104">Eventname 2 (T104) (09-05-2015)</option>
<option value="109">Eventname 3 (M109) (15-05-2015)</option>
<option value="99" selected="selected">Eventname 4 (M99) (24-04-2015)</option>
</select>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}