use strict;
my $str = '<select id="filter_event_id" name="filter_event_id" class="inputbox chzn-done" onchange="submit();" style="display: none;">
<option value="0">Select Event</option>
<option value="113">Eventname (RB113) (02-05-2015)</option>
<option value="104">Eventname 2 (T104) (09-05-2015)</option>
<option value="109">Eventname 3 (M109) (15-05-2015)</option>
<option value="99" selected="selected">Eventname 4 (M99) (24-04-2015)</option>
</select>';
my $regex = qr/^.*?(\bEventname 2\b).*$/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}