re = /(?<=,|^)[0.+-]+(?=0(?:,|$))|\.0+\b|\b0+(?=\.)/
str = '2.0,3.00,-4.0,0.00,-0.00,0.03,2.01,0.001,-0.03,101'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result