import Foundation
let pattern = #"(?<=,|^)[0.+-]+(?=0(?:,|$))|\.0+\b|\b0+(?=\.)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"2.0,3.00,-4.0,0.00,-0.00,0.03,2.01,0.001,-0.03,101"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)