using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"( )(?=[^<]+>)";
string substitution = @"_";
string input = @"<please help me> hello everyone <HI!>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}