$re = '/\d{3}\.\d{3}\.\d{1}\.\d{1}/m';
$str = '192.168.1.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);