#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^-?(?!.{12})\d+(?:\.\d+)?$"
Local $sString = "66666666666" & @CRLF & _
"-66666666666" & @CRLF & _
".6666666666" & @CRLF & _
"6.666666666" & @CRLF & _
"66.66666666" & @CRLF & _
"666.6666666" & @CRLF & _
"6666.666666" & @CRLF & _
"66666.66666" & @CRLF & _
"666666.6666" & @CRLF & _
"6666666.666" & @CRLF & _
"66666666.66" & @CRLF & _
"666666666.6" & @CRLF & _
"6666666666." & @CRLF & _
"6666666.6666" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")