using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!https?:)\/\/(.+?)(?<!https?:)\/\/";
string input = @"fff https://stackoverflow.com<br><br>bar https://stackoverflow.com. <br>foo<br>1. //ok// - bar. //ok// - bar. //ok// - foo. //ok// - bar<br>6. //ok// -((https://stackoverflow.com)), ok (((https://stackoverflow.com bar))), fooo/ bar<br> //ok (https://stackoverflow.com bar))).//<br> foo (((https://stackoverflow.com foo)) - ";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}