re = /(?<!https?:)\/\/(.+?)(?<!https?:)\/\//mi
str = 'fff https://stackoverflow.com<br><br>bar https://stackoverflow.com. <br>foo<br>1. //ok// - bar. //ok// - bar. //ok// - foo. //ok// - bar<br>6. //ok// -((https://stackoverflow.com)), ok (((https://stackoverflow.com bar))), fooo/ bar<br> //ok (https://stackoverflow.com bar))).//<br> foo (((https://stackoverflow.com foo)) - '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end