import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?![^<]*>|[^<>]*<\\/)((https?:)\\/\\/[a-z0-9&#=.\\/\\-?_]+)";
final String string = "Posting a link: http://test.com, posting an image <img src=\"http://test.com/2.jpg\" />. Posting an actual A tag: <a href=\"http://test.com/test.html\">http://test.com/test.html</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}