re = /\[!--[^-]*--\](*SKIP)(*F)|(?:(?!\[!--[^-]*--\]).)+/
str = 'nine hundred ninety [!--$element--] two hundred thirteen'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end