package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:x)([0-9]+)`)
var str = `x14`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}