#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<\s*span[^>]*>(.*?)<.*?\/span>" & @CRLF & _
""
Local $sString = " <div class="list-group">" & @CRLF & _
" <input type="checkbox" dataid="101" />" & @CRLF & _
" <a href="techno1">2023</a>" & @CRLF & _
" <span> 615 <a href="techno"><i class="fa fa-chevron-circle-right"></i></a></span>" & @CRLF & _
" </div>" & @CRLF & _
" " & @CRLF & _
" <div class="list-group">" & @CRLF & _
" <input type="checkbox" dataid="102" />" & @CRLF & _
" <a href="techno2">2023</a>" & @CRLF & _
" <span> 715 <a href="techno"><i class="fa fa-chevron-circle-right"></i></a></span>" & @CRLF & _
" </div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")