using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<\s*span[^>]*>(.*?)<.*?\/span>
";
string input = @" <div class=""list-group"">
<input type=""checkbox"" dataid=""101"" />
<a href=""techno1"">2023</a>
<span> 615 <a href=""techno""><i class=""fa fa-chevron-circle-right""></i></a></span>
</div>
<div class=""list-group"">
<input type=""checkbox"" dataid=""102"" />
<a href=""techno2"">2023</a>
<span> 715 <a href=""techno""><i class=""fa fa-chevron-circle-right""></i></a></span>
</div>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}