import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\s*span[^>]*>(.*?)<.*?\\/span>\n";
final String string = " <div class=\"list-group\">\n"
+ " <input type=\"checkbox\" dataid=\"101\" />\n"
+ " <a href=\"techno1\">2023</a>\n"
+ " <span> 615 <a href=\"techno\"><i class=\"fa fa-chevron-circle-right\"></i></a></span>\n"
+ " </div>\n"
+ " \n"
+ " <div class=\"list-group\">\n"
+ " <input type=\"checkbox\" dataid=\"102\" />\n"
+ " <a href=\"techno2\">2023</a>\n"
+ " <span> 715 <a href=\"techno\"><i class=\"fa fa-chevron-circle-right\"></i></a></span>\n"
+ " </div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}