$re = '/<\s*span[^>]*>(.*?)<.*?\/span>
/m';
$str = ' <div class="list-group">
<input type="checkbox" dataid="101" />
<a href="techno1">2023</a>
<span> 615 <a href="techno"><i class="fa fa-chevron-circle-right"></i></a></span>
</div>
<div class="list-group">
<input type="checkbox" dataid="102" />
<a href="techno2">2023</a>
<span> 715 <a href="techno"><i class="fa fa-chevron-circle-right"></i></a></span>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);