$re = '/^[a-zA-Z]:(\\\\\\\\[^\\\\ ]+)*/im';
$str = 'C:\\\\dd\\\\sd\\\\faf.txt true
c:\\\\ss\\\\dw\\\\fbf.txt true
D:\\\\ff\\\\d3\\\\fcf.txt true
d:\\\\da\\\\ds\\\\Df\\\\ff.txt true
2:\\\\ad\\\\dd\\\\ff false
2:\\ad\\\\dd\\\\ff false
d:\\da\\\\ds\\\\Df\\\\ff.txt false
c\\\\ss\\\\dw\\\\fbf.txt false
D:\\da\\\\ds\\\\Df\\\\ff.txt false
D:\\\\da\\\\ds\\Df\\\\ff.txt false';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);