package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-zA-Z0-9._-]+@[a-zA-Z0-9._-]+\.[a-zA-Z0-9._-]+)`)
var str = `adminvicky@gmail.com Active 12/05/2015 03:07
adminvishal250@gmail.com Pending Verification 8/05/2015 01:07`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}