$re = '/(\d{4})(-)?(\d{2})(-)?(\d{2})(T)?(\d{2})(\:)?(\d{2})(\:)?(\d{2})(\+(\d{2}:\d{2})|\.(\d{3}Z)|Z)/m';
$str = '2016-04-19T19:54:52.273Z
2016-04-20T11:54:59+00:00
2016-04-20T11:54:59Z
20160420T115459Z';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);