re = /^(?=.*?[0-9])(?=.*?[a-z])(?=.*?[A-Z])(?=.*?[^\w\s]).{8,20}$/
str = 'Tekken.1'
# Print the match result
str.match(re) do |match|
puts match.to_s
end