use strict;
my $str = 'dfdsfdsfdsfd..dd
dfdsfdsfdsf...dd
dfdsfd--dsfd..dd
dfdsfdsfdsf.d.dd
dfdsfdsfdsf-.-dd
df.sfdffdsfd..dd
ffdsfdsfd--sf.dd
ffdsfdsfdffsffd.
.fdsfdsfdr-sfrdd
ffdsfds.td-sftdd';
my $regex = qr/^(?!(?:.*-){2}|(?:.*\.){2})[a-zA-Z\d][a-zA-Z\d.-]{14}[a-zA-Z\d]$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}