use strict;
my $str = 'AgCocoaBridgeView id="ImportGridView"Index: 1Name: 1SingleImport.CR2{15,223,193,253} = Index: 1Name: 1SingleImport.CR2 = Index: 1Name: 1SingleImport.CR2';
my $regex = qr/(?:id="ImportGridView"Index: )(.)(?:Name:)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}