$re = '/(http|https):\/\/(?:www\.)?puu\.sh\/(\w{5})\/(\w{10})\.(\w{3})/i';
$str = 'https://puu.sh/qpMlC/b58dea7700.png
http://puu.sh/qpDOW/eb0ba4f4b2.jpg
http://puu.sh/qpPfI/b74edd1b8e.png';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);