$re = '%([\.\,\?!;:\(\)\(\)\{\}\-\+`\\\\\^\[\]\^"]\S|(\'\S*\'))%u';
$str = 'ee maa i dasda!s2di []adasd';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);