// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)SI-?(\d{2,5})[\s|-]*(III|IV|V|6|6s)[\s|-]+(\w{4,6})[\s|-]+[ø|Ø|d]?\s?(\d{2})").unwrap();
let string = "SI-130-6 F75D Ø40";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}