# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<script.*src=)("|')(.*)('|")/\1\2myscript.js\4/;t' <<< "<script type=\"javascript\" src='oldscript.js' ></script>
<img src='test.jpg' />"