import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<script.*src=)(\"|')(.*)('|\")";
final String string = "<script type=\"javascript\" src='oldscript.js' ></script>\n"
+ "<img src='test.jpg' />";
final String subst = "\\1\\2myscript.js\\4";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}