$re = '/(<script.*src=)("|\')(.*)(\'|")/';
$str = '<script type="javascript" src=\'oldscript.js\' ></script>
<img src=\'test.jpg\' />';
$subst = "\1\2myscript.js\4";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;