import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "http(?:s)?\\://boards\\.4chan\\.org/([a-z]*)/thread/([0-9]*)(?:\\#[0-9a-z]*)?";
final String string = "https://boards.4chan.org/mlp/thread/5\n"
+ "http://boards.4chan.org/b/thread/570277846\n"
+ "https://boards.4chan.org/mlp/thread/19865655#q19865655\n"
+ "https://boards.4chan.org/mlp/thread/19775771\n"
+ "https://boards.4chan.org/co/thread/65737750#q65737750";
final String subst = "Thread $2 on mlp";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}