$re = '/http(?:s)?\://boards\.4chan\.org/([a-z]*)/thread/([0-9]*)(?:\#[0-9a-z]*)?/';
$str = 'https://boards.4chan.org/mlp/thread/5
http://boards.4chan.org/b/thread/570277846
https://boards.4chan.org/mlp/thread/19865655#q19865655
https://boards.4chan.org/mlp/thread/19775771
https://boards.4chan.org/co/thread/65737750#q65737750';
$subst = "Thread $2 on mlp";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;