# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\s+|\s*"\s*|\s*<.*|\S+@\S+|\s*\(\s*|\s*\)\s*/\t/g;t' <<< "dano@xpotential.com (notes here)
John Doe
\" John Doe \" <johndoe@example.com>"