using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s+|\s*""\s*|\s*<.*|\S+@\S+|\s*\(\s*|\s*\)\s*";
string substitution = @"\t";
string input = @"dano@xpotential.com (notes here)
John Doe
"" John Doe "" <johndoe@example.com>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}