const regex = new RegExp('^\\s+|\\s*"\\s*|\\s*<.*|\\S+@\\S+|\\s*\\(\\s*|\\s*\\)\\s*', 'g')
const str = `dano@xpotential.com (notes here)
John Doe
" John Doe " <johndoe@example.com>`;
const subst = `\t`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);