import re
regex = re.compile(r"^\s+|\s*\"\s*|\s*<.*|\S+@\S+|\s*\(\s*|\s*\)\s*")
test_str = ("dano@xpotential.com (notes here)\n"
" John Doe\n"
"\" John Doe \" <johndoe@example.com>")
subst = "\\t"
result = regex.sub(subst, test_str)
if result:
print(result)