$re = '//\*[\s\S]*\*//';
$str = '/* first line.
the second line
The last line. */
/* asdlfas;dlf */
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);