re = /\/\*[\s\S]*\*\//
str = '/* first line.
the second line
The last line. */
/* asdlfas;dlf */
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end